Hauptmenü

Nachfolgend finden Sie Erklärungen zu den Menüpunkten:

Datei

Neu

Über diesen Menüpunkt kann ein neues leeres Package, Projekt oder Mapping erstellt werden. Packages können entweder leer oder nach einer Vorlage erstellt werden. Das Konzept für Projekt-, Package- und Analysepackage-Templates ist in Templates beschrieben.

Öffnen

Über diesen Menüpunkt kann ein weiteres Package, Projekt oder Mapping geladen werden. Zusätzlich besteht die Möglichkeit einen Testreport in Form einer .trf, .prf oder .prfz-Datei zu öffnen, die anschließend im Report Viewer angezeigt wird.

Link öffnen

Mit diesem Menüpunkt kann über einen Dialog mithilfe des tracetronic://-Protokolls (Beispiel: "tracetronic:///C:/.../Package.pkg") ein weiteres Package oder Projekt geladen werden. Hier besteht ebenfalls die Möglichkeit, einen Testreport zu öffnen, der anschließend im Report Viewer angezeigt wird. Das Kontextmenü des Report Viewers erlaubt das Kopieren von Package- und Report-Links.

Zuletzt geöffnet

Hier werden die zuletzt geöffneten Packages und Projekte aufgelistet, um schnell wieder auf diese zugreifen zu können. Über das Menü Optionen ‣ Einstellungen ‣ Historie kann die Anzahl der angezeigten Elemente festgelegt werden.

[Ziel]

Dieser Menüpunkt zeigt, auf welches Artefakt (Package, Projekt, Mapping, …) sich die folgenden Befehle (Schließen, Speichern, …) beziehen und führt selbst keine Aktion aus.

Schließen

Das darüber in eckigen Klammern angezeigte Package/Projekt wird geschlossen.

Speichern (unter / als Template)

Das darüber angegebene Package/Projekt kann über diesen Menüpunkt gespeichert werden. Wahlweise kann es als Template zur späteren Verwendung abgelegt werden. Allgemeine Hinweise zur Nutzung von Templates sind im Abschnitt Templates beschrieben.

Alle Editoren speichern

Speichert alle im Editor geöffneten Dateien. Handelt es sich um neue, ungespeicherte Dateien fragt ecu.test nach dem Zielpfad.

Importieren

Importiert ein Package, ein Projekt oder eine Testkonfiguration aus angebundenen Testmanagementsystemen oder aus Archiven. Weitere Informationen zum Importieren von Projektarchiven finden Sie unter Importieren und Exportieren, weitere Informationen zu Testkonfigurationsarchiven unter Importieren und Exportieren.

Exportieren

Über diesen Menüpunkt können komplette Projekte (einschließlich der referenzierten Packages und Konfigurationen) oder Testkonfigurationen mit zugehörigen Artefakten in eine Archiv-Datei exportiert werden, um sie auf andere Prüfplätze übertragen und dort wieder importieren zu können. Außerdem können Projekte, Packages und Ergebnisse in ein unterstütztes Testmanagementsystem exportiert werden. Weitere Informationen zum Exportieren von Projektarchiven finden Sie unter Importieren und Exportieren, weitere Informationen zu Testkonfigurationsarchiven unter Importieren und Exportieren.

Workspace wechseln

Mit diesem Menüpunkt kann der Neustart von ecu.test in einen anderen Workspace initiiert werden.

Beenden

ecu.test wird beendet.

Bearbeiten

Für die Bearbeitung von Testschritten eines Packages stehen die folgenden Funktionen zur Verfügung:

  • Rückgängig

  • Wiederherstellen

  • Ausschneiden

  • Kopieren

  • Einfügen

  • Entfernen

  • Alles markieren

  • Suchen

Ansicht

Über diesen Menüpunkt kann die aktuelle Ansicht gewählt werden. Sollte man die Anordnung der Fenster geändert haben, kann man über den Menüpunkt Ansicht zurücksetzen zum ursprünglichen Aussehen zurückkehren.

Fenster

Hier kann gewählt werden, welche Fenster in der aktuellen Ansicht angezeigt werden sollen. Beispielsweise kann das Meldungsfenster die Ablaufgeschwindigkeit negativ beeinflussen und hier ausgeblendet werden. (Auch wenn das Meldungsfenster ausgeblendet ist, wird es weiter befüllt).

Optionen

Einstellungen

Es öffnet sich das Einstellungsmenü, in dem die Standardverzeichnisse, die Protokollstufe, verwendete Sprache und Löschen der Historie verwaltet werden können.

Extras

trace.xplorer (basic)

Öffnet in Abhängigkeit von den Einstellungen zur Signalvisualisierung entweder den trace.xplorer basic oder den trace.xplorer, in denen Signale einer Tracedatei grafisch dargestellt und untersucht werden können.

Signal Editor

Der Signal Editor zum Erstellen eigener Signalverläufe, welche als Stimuli oder Referenzaufnahmen in ecu.test eingebunden werden können, kann hier gestartet werden.

Utility Wizard

Der Utility Wizard zum Erstellen eigener Utilities kann hier gestartet werden.

Benutzer-Python-Bibliothek bearbeiten

Öffnet einen einfachen Editor für benutzerdefinierte Pythonfunktionen, in dem man Änderungen vornehmen kann. Nach dem Speichern und Schließen des Dialogs wird die Bibliothek in ecu.test aktualisiert, so dass die Änderungen ohne Neustart zur Verfügung stehen.

Benutzer-Python-Bibliothek aktualisieren

Wenn die Python-Bibliothek außerhalb von ecu.test geändert wurde, kann man mit diesem Punkt die Dateien neu einlesen.

Coverage

Ermöglicht das Laden und Entfernen von Coverage-Informationen. Durch die vorherige Aktivierung der entsprechenden TCF-Option kann bei der Ausführung eines Testfalls die Testfall-Coverage ermittelt und im Package-Editor visualisiert werden.

  • Einzelne Coverage-Datei laden: Extras ‣ Coverage ‣ Coverage-Datei laden…

  • Alle Coverage-Dateien innerhalb eines Verzeichnisses laden: Extras ‣ Coverage ‣ Coverage-Dateien aus Verzeichnis laden…

  • Laden von Coverage-Dateien via eines Projektfilters aus test.guide-Reports Extras ‣ Coverage ‣ Coverage via Filter aus test.guide laden…

  • Coverage-Report für alle geladenen Coverage-Dateien erzeugen: Extras ‣ Coverage ‣ Coverage-Report erstellen

  • Coverage-Visualisierung zurücksetzen: Extras ‣ Coverage ‣ Alle geladenen Coverage-Dateien löschen…

ecu.test drive

Öffnet ecu.test drive im Browser oder den Konfigurationsdialog um dessen Server zu starten.

ecu.test lab

Öffnet ecu.test lab im Browser oder den Konfigurationsdialog um dessen Server zu starten.

Hilfe

Hilfe

Diese Hilfe wird geöffnet.

Change-Log

Die Änderungshistorie von ecu.test wird angezeigt.

Support-Anfrage

Öffnet den Support Wizard für die Sammlung von Informationen zur Übermittlung an den technischen Support für den Fall das Probleme auftreten.

Willkommensseite

Öffnet die Informationsseite zu Neuerungen der aktuellen Version im Editor.

Info

Infos über ecu.test werden angezeigt.