Skip to content
logo
ecu.test 2025.3 Help
Menu items
  • English
  • Deutsch
Initializing search
    • Getting Started
    • Overview
    • ecu.test Main program
    • Further included programs
    • Tools
    • Test execution
    • Trace analysis
    • Workspace
    • Handling
      • Keyboard shortcuts
      • Menu items
        • File
        • Edit
        • View
        • Window
        • Options
        • Extras
        • Help
      • Search
      • Filter
      • EasyInsert
      • Text fields with Python expression support
      • Remote control of ecu.test
      • Automatic installation
      • Patches
      • Performance tips
    • Test management
    • test.guide
    • Extensions
    • Specific Tutorials
    • API references
    • System requirements
    • ecu.test on Linux
    • ecu.test code
    • ecu.test agent
    • ecu.test lab
    • File
    • Edit
    • View
    • Window
    • Options
    • Extras
    • Help

    Menu items¶

    The menu items are described in the following explanations:

    • File

    • Edit

    • View

    • Window

    • Options

    • Extras

    • Help

    File¶

    New

    A new and empty package, project or mapping can be cretaed at this menu item. Packages can be generated either empty or by using a template.

    Open

    This menu item serves to load a further package, project or mapping. There is the additional possibility of opening a test report in the form of a file .trf which will then be displayed in the Report viewer.

    Open link

    This menu item can be used to load another package or project via a dialog using the tracetronic:// protocol (example: "tracetronic:///C:/.../Package.pkg"). It is also possible to open a test report via this dialog, which is then displayed in the Report viewer. The context menu of the report viewer allows copying package and report links.

    Last opened

    Here the packages and projects are shown which were opened last; so they can be accessed quickly again. By means of the menu Options ‣ Settings‣ History you can determine the number of elements to be shown.

    [Target]

    This menu item shows only the target (package, project, mapping, …) on which the following commands (Close, Save) will be executed. No command is executed by selecting this item.

    Close

    The package/project displayed here in square brackets will be closed.

    Save (as/as template)

    The package/project shown above can be saved by using this menu item. There is also an option to save the packages/project as a template for later reuse.

    Save all editors

    All files opened in the editor are saved. If these are new files, ecu.test queries for destination pahes.

    Import

    Imports a package or project from connected test management systems or from archives.

    Export

    Complete projects (including referenced packages and configurations) can be exported into an archive file to be transferred to other test sites where they can be re-imported. Furthermore, projects, packages and results can be exported to a supported test management system.

    Change Workspace

    ecu.test will be restarted in another workspace.

    Exit

    ecu.test is terminated.

    Edit¶

    The following functions are available for editing test steps:

    • Undo

    • Redo

    • Cut

    • Copy

    • Paste

    • Delete

    • Mark all

    • Search for

    View¶

    Should the arrangement of windows have been changed, the menu items Reset view serves to go back to the original view.

    Window¶

    Here it can be determined which windows should be shown in the current view. The Messages window, for example, can have a negative influence on execution speed and can be blanked out here (it will continue to be filled even while blanked out).

    Options¶

    Settings

    The settings menu opens, in which default directories, the protocol level, the program language and deletion of history can be managed.

    Extras¶

    trace.xplorer (basic)

    Opens either the trace.xplorer basic or the trace.xplorer depending on the signal visualization settings. Both can be used to plot and analyze the signals of a trace file.

    Signal Editor

    The Signal Editor for creating own signal patterns, which can be integrated in ecu.test as stimuli or reference recordings, can be started here.

    Utility Wizard

    The utility wizard for generating your own utilities can be started here.

    Edit user python library

    Opens a simple editor for user-defined Python functions, in which modifications can be made. After saving and closing the dialog, the library is updated in ecu.test so that the modifications are available without a new start.

    Update user libraries

    If the Python library was modified outside of ecu.test, the files can be re-read here.

    Import ReqIf

    Opens a dialog for the import of requirements from ReqIf files. The imported requirements can then be added as an attribute to the attribute definitions of packages and projects.

    Coverage

    Enables coverage information to be loaded and removed. By activating the corresponding TCF option beforehand, the Test case coverage can be determined and visualized in the package editor when a test case is executed.

    • Load single coverage file: Extras ‣ Coverage ‣ Load coverage file…

    • Load all coverage files within a directory: Extras ‣ Coverage ‣ Load coverage files from directory…

    • Load coverage files via a project filter from test.guide reports Extras ‣ Coverage ‣ Load coverage via filter from test.guide…

    • Create a coverage report for all loaded coverage files: Extras ‣ Coverage ‣ Generate Coverage Report

    • Reset coverage visualization: Extras ‣ Coverage ‣ Clear all loaded coverage files…

    Help¶

    Help

    Help is opened.

    Change log

    The change history of ecu.test is displayed.

    Support request

    Opens the Support wizard to collect information to be send to the technical support in case of problems.

    Welcome page

    Opens the information page with new features of the current version in the editor.

    Info

    Information about ecu.test is displayed.

    2025-12-05
    Previous
    Keyboard shortcuts
    Next
    Search
    © Copyright 2025, tracetronic GmbH.
    Created using Sphinx 8.2.3. and Sphinx-Immaterial
    Logo of tracetronic GmbH
    legal notice privacy policy